First Orion Customer Portal Outage
Incident Report for First Orion Status
Resolved
The customer portal issue has been resolved
Posted Mar 06, 2024 - 16:09 CST
Update
We are continuing to work on a fix for this issue.
Posted Mar 06, 2024 - 15:44 CST
Identified
We are experiencing issues due to an active customer portal release. The issue has been identified and will be addressed within the hour, Branding was not impacted
Posted Mar 06, 2024 - 15:42 CST
This incident affected: Customer Portal.